Forge apps may not receive events from the Forge Bridge APIs

Incident Report for Atlassian Developer

Resolved

This incident has been resolved.
Posted Jan 23, 2025 - 08:49 UTC

Monitoring

We have fixed an issue in the Forge UI Bridge API that prevented subscribers from receiving events.

This impacted Forge apps using the event.emit and event.on methods from the API in Jira and Confluence.

Impact started:
Confluence: 2025-01-17 05:00 UTC
Jira: 2025-01-20 08:00 UTC

The incident has been resolved in all regions as of 2025-01-23 08:40 UTC.
Posted Jan 23, 2025 - 08:40 UTC

Investigating

We have developed a fix to resolve the issue impacting Forge apps not receiving events via the Forge UI Bridge.

We anticipate the deployment will occur over the next 2-3 hours.

We will provide another update by 2021-01-23 08:00 UTC, in 2 hours from now
Posted Jan 23, 2025 - 06:31 UTC

Update

We have identified the issue impacting Forge apps not receiving events via the Forge UI Bridge.

We are creating a fix and will deploy once ready.

We will provide an update 2025-01-23 06:30 UTC in 2 hours from now
Posted Jan 23, 2025 - 04:40 UTC

Identified

We have identified the issue preventing events being sent with the Forge UI bridge API in some apps.

We are now working on a fix and will provide an update by 2025-01-23 03:30 UTC, in 2 hours from now.
Posted Jan 23, 2025 - 01:34 UTC

Investigating

We are investigating an issue where Forge apps my not receive events from the Forge UI Bridge.

This will cause Forge apps to operate inconsistently or not at all.

We will provide another update by 2025-01-23 01:30 UTC, in 2 hours from now.
Posted Jan 22, 2025 - 23:37 UTC
This incident affected: Developer (Forge CDN (Custom UI)).