Errors while invoking forge functions for newly installed apps
Incident Report for Atlassian Developer
Resolved
We are now marking this incident as resolved.
We apologize for any inconveniences this may have caused you, your team, and our mutual customers.
Posted Feb 14, 2024 - 02:26 UTC
Monitoring
The impact of this incident has been mitigated and our monitoring tools confirm that Forge app installations are back to normal

We will continue to monitor this for the next few hours
Posted Feb 14, 2024 - 00:04 UTC
Identified
We have identified an issue with Forge function invocation that is impacting some Atlassian Cloud customers with newly installed Forge apps.

Due to a race condition, some install events 'avi:forge:installed:app' were not delivered after the Forge app was installed on a customer Cloud site.

We estimate that a maximum of 108 apps were impacted, totaling about 1K app installations.

Timeline

2024-02-08 00:00 UTC: impact start
2024-02-12 20:00 UTC: impact detected
2024-02-13 21:00 UTC: solution identified

We have identified the root cause and are currently rolling out a fix.

We will provide another update in 1 hour
Posted Feb 13, 2024 - 21:30 UTC
Investigating
We are investigating an issue with Forge function invocation that is impacting some Atlassian Developer Cloud customers with newly installed Forge apps. We will provide more details within the next two hours.
Posted Feb 13, 2024 - 18:27 UTC
This incident affected: Developer (Forge Function Invocation).