Apps intermittently fail to load in the Developer Console
Incident Report for Atlassian Developer
Resolved
Dev Console is back to normal and stable for the last one hour and no new issues are noted.
This is the final update on this incident, no further comms will be published.
Posted Apr 25, 2024 - 05:16 UTC
Monitoring
A root cause has been identified. Marketplace is seeing unusual traffic, and as a preventive measure, couple of offending user-agents were blocked. Rate limits rejections have reached a healthy state and Dev Console is back to normal. No failures in Dev Console loading are observed at this point.

Next update will be posted in 1 hour.
Posted Apr 25, 2024 - 04:36 UTC
Investigating
We have identified a problem with the Developer Console where apps intermittently fail to load on the landing page. We are investigating the root cause and will provide another update in the next 2 hours.
Posted Apr 25, 2024 - 01:47 UTC
This incident affected: Developer (Developer console).