Attachments download using OAuth in Confluence
Incident Report for Atlassian Developer
Resolved
A fix has been released. We have created a new documented REST API endpoint and OAuth scope that apps can use to download attachments. See the Developer Community forums for the full details: https://community.developer.atlassian.com/t/new-download-attachment-rest-api-endpoint/50398
Posted Jul 30, 2021 - 20:28 UTC
Update
The work to provide a fix is still continuing and now expected to be complete early next week. It consists of a new download API and corresponding OAuth scope which will be documented. An update will be posted here and the Developer Community forums (https://community.developer.atlassian.com) when the fix is available.
Posted Jul 21, 2021 - 20:50 UTC
Identified
A fix has been identified and is in progress, current ETA is early next week.
Posted Jul 15, 2021 - 01:29 UTC
Update
We are continuing to investigate this issue.
Posted Jul 14, 2021 - 00:59 UTC
Investigating
We are currently investigating an issue where apps cannot download attachments using OAuth in Confluence.
Posted Jul 14, 2021 - 00:58 UTC
This incident affected: APIs (Confluence Cloud APIs).