Some app downloads failing on Marketplace
Incident Report for Atlassian Developer
Resolved
Downloads are now working correctly again.
Posted May 25, 2020 - 12:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 25, 2020 - 11:57 UTC
Update
We applied the necessary config change to our Cloudfront CDN, and downloads started working again.
Posted May 25, 2020 - 11:40 UTC
Investigating
Downloads were failing for some but not all server and DC downloads.

This was due to a reverse proxy configuration change that was made today in order to improve security. The change caused our Cloudfront CDN config to become invalidated because it was pointing to a now-defunct URL. Some downloads continued to work because they were already cached in Cloudfront. Our monitoring also failed to pick up the failure because it was hitting these cached apps.
Posted May 25, 2020 - 05:00 UTC
This incident affected: Marketplace (In-product Marketplace and app installation (Server)).