Between 2023-02-19 23:00 UTC to 2023-02-20 13:30 UTC, Some Jira REST API calls received 500 responses. This affected requests that are related to parent search clause. The issue has now been resolved and the service is operating normally.
Posted Feb 21, 2023 - 02:01 UTC
Identified
We have identified root cause of this incident and are in the process of rolling out fix.
Current impact: for some REST API requests Jira is returning 500 errors. This only affects requests that are related to parent search clause (for example: 'Parent Link' is empty) - although the relation could be due to the stored JQL and not directly passed in request body (for example when evaluating existing JQL filter with affected clause). It mainly impacts Jira Expression Evaluation and Search REST endpoints but is not limited to those.
Impact start: 2023-02-19 22:30 UTC.
The fix is being rolled out progressively and should complete by 21:00 UTC.
Next update will be posted around 22:00 UTC unless situation changes significantly.
Posted Feb 20, 2023 - 12:19 UTC
Investigating
We have identified a problem with Jira Cloud where some API calls involving parent related search clauses in JQL are resulting in 500 errors. This problem appears in Jira search, Jira Expression evaluation and other related APIs. The problem started appearing to small amount of REST API calls around 2023-02-19 22:30 UTC. We are investigating the root cause and will provide another update by 12:00 UTC.