The issue affecting the display of data on the Usage and Charges page in the Forge Developer Console has been largely resolved. All charge elements, except for Forge Compute, are now displaying accurate values. We are actively working to resolve the remaining issue with Forge Compute. We will provide another update once this final issue has been fully mitigated.
Posted Dec 16, 2025 - 16:14 UTC
Monitoring
The issue affecting the display of data on the Usage and Charges page in the Forge Developer Console has been largely resolved. All charge elements, except for Forge Compute, are now displaying accurate values.
We are actively working to resolve the remaining issue with Forge Compute. We will provide another update once this final issue has been fully mitigated.
Posted Dec 16, 2025 - 16:14 UTC
Update
We have identified an issue with the Forge Developer Console not displaying data on the Usage and Charges page. We are actively working to resolve this issue and will provide more details within the next hour.
Posted Dec 16, 2025 - 05:47 UTC
Identified
We have identified an issue with the Forge Developer Console, which is not displaying data on the Usage and Charges page. We are actively working to resolve this issue and will provide more details within the next hour.
Posted Dec 16, 2025 - 05:47 UTC
This incident affects: Developer (Developer console).