Intermittent Connect App Upgrade issue results in Apps in Disabled state
Incident Report for Atlassian Developer
Resolved
The root cause has been identified and fixed, and all impacted Connect apps for Jira and Confluence have been re-enabled. Our monitoring has not observed reoccurrences of the problem.

In a previous update we advised caution in making descriptor updates as we investigated the issue and its underlying causes. Now that the problem has been resolved, you may safely proceed with making updates to marketplace apps.

[This message was updated at 2024-04-19 06:15 UTC to clarify that the underlying root cause had been addressed and that it is now safe to publish descriptor updates.]
Posted Apr 18, 2024 - 15:47 UTC
Monitoring
All identified disabled Connect apps for Jira and Confluence have been enabled. Major impact is mitigated as for now.

We will continue monitoring the situation. Will provide another update in 24 hours (by 2024-04-17 10:00 UTC).
Posted Apr 16, 2024 - 10:25 UTC
Update
We continue to investigate the intermittent enablement failures impacting some Connect apps. Concurrently, we are also exploring a pathway to re-enable impacted app installations, so that apps will be restored for customers.

We will post updates within the next 3 hours.
Posted Apr 16, 2024 - 07:02 UTC
Investigating
In response to some recent customer and partner support tickets which have been raised, we have identified that since 2024-04-08 there have been some Connect app installations and updates which have immediately entered a disabled state. This behaviour is affecting multiple apps and appears to be inconsistent in nature.

The impact relates to any new Connect app installation or any updates which occur to a Connect app. For this reason, we suggest that marketplace partners hold off on any descriptor updates until this incident is resolved.

For affected customers that are unable to re-enable these apps, the immediate workaround is to uninstall and reinstall the app, forcing the app to attempt enablement once again.

We do not yet have any expected resolution time or any other mitigations for apps or customers.

We will continue to investigate the cause of this incident and provide another update by 2024-04-16 07:00.
Posted Apr 16, 2024 - 05:39 UTC
This incident affected: Marketplace (In-product Marketplace and app installation (Cloud)).