Incident impacting Forge app installations and Dev console

Incident Report for Atlassian Developer

Resolved

On March 17th, 2026, between 9:05 AM UTC and 11:10 AM UTC, Forge app management and related developer tooling experienced some service disruption. The issue has now been resolved, and the service is operating normally for affected customers.
Posted Mar 17, 2026 - 11:37 UTC

Update

We are investigating an incident impacting Forge app management and related developer tooling. Customers may experience errors when attempting to:

-Install, upgrade, or deploy Forge apps
-Use Forge app tunnelling (particularly newly created tunnels and tunnels older than 30 minutes)
-Access or manage apps via the Atlassian Developer Console

In addition, some underlying app platform capabilities used by Forge and related services are affected, including:

-Certain app data residency operations
-Rovo MCP consent flows and other app management operations that rely on the app platform

At this time, existing Forge apps continue to run, and app invocations are not impacted.
Our engineering teams are actively investigating the issue and working to restore normal operation. We will provide the next update in 60 mins or sooner if we have significant progress to share.
Posted Mar 17, 2026 - 10:59 UTC

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 10:34 UTC

Investigating

We are actively investigating reports of performance degradation affecting Forge apps and Developer console will share updates here as more information becomes available.
Posted Mar 17, 2026 - 10:05 UTC
This incident affected: APIs (Bitbucket Cloud APIs, Confluence Cloud APIs, Jira Cloud APIs, Product Events, User APIs, Webhooks, Web Triggers), Marketplace (App listing management, App listings, App pricing, App submissions, Category landing pages, Evaluations and purchases, In-product Marketplace and app installation (Cloud), In-product Marketplace and app installation (Server), Notifications, Private listings, Reporting APIs and dashboards, Search, Vendor management, Vendor Home Page), Developer (App Deployment, Artifactory (Maven repository), Create and manage apps, Developer documentation, Forge App Installation, Forge CDN (Custom UI), Forge Function Invocation, aui-cdn.atlassian.com, Forge App Logs, Forge App Monitoring, Developer console, Forge direct app distribution, Hosted storage, Forge CLI, End-user consent, Forge App Alerts, App Data Residency, Forge SQL), Support (Atlassian Support contact form, Developer community, Developer service desk, Marketplace service desk, Atlassian Support, Vulnerability management [AMS]), and Authentication and user management.