Jira OAuth 2.0 REST calls are returning incomplete data for some endpoints
Incident Report for Atlassian Developer
Resolved
Since Monday 26th Feb some of Jira OAuth 2.0 REST calls that result in returning an empty or incomplete set of data for issue related endpoints (some of identified endpoints are /rest/api//issue/createmeta, /rest/api/, /rest/api//issue//editmeta).

Following rollback of the recently released code change on Feb 29th 12:20 UTC we haven't observed failures and haven't received any new reports. The incident is now resolved.

We apologise to all of our customers and users who were impacted during this time.
Posted Feb 29, 2024 - 18:27 UTC
Monitoring
Since Monday Feb 26th some of Jira OAuth 2.0 REST calls that result in returning an empty or incomplete set of data for issue related endpoints (some of identified endpoints are /rest/api//issue/createmeta, /rest/api/, /rest/api//issue//editmeta).

We have identified root cause of the issue and resolved it by rolling back one of the recently released code changes. We are seeing reduced number of authentication errors and will continue monitoring before confirming incident as resolved.

We'll provide next update by 17:00 UTC, in 2 hours from now.
Posted Feb 29, 2024 - 15:30 UTC
Update
We continue to investigate issue affecting some of Jira OAuth 2.0 REST calls that result in returning an empty or incomplete set of data for issue related endpoints (some of identified endpoints are /rest/api//issue/createmeta, /rest/api/, /rest/api//issue//editmeta).

We're testing few hypothesis on the root cause and will provide another update by 15:00 UTC, in 2 hours from now
Posted Feb 29, 2024 - 12:55 UTC
Investigating
We have identified a problem with some Jira OAuth 2.0 REST calls that result in returning an empty or incomplete set of data for issue related endpoints (some of identified endpoints are /rest/api//issue/createmeta, /rest/api/, /rest/api//issue//editmeta).

We are investigating the root cause and will provide another update by 12:00 UTC.
Posted Feb 29, 2024 - 10:15 UTC
This incident affected: Authentication and user management.