Intermittent issues in Forge Function Invocation capability
Incident Report for Atlassian Developer
Resolved
Our monitoring since implementing the previously mentioned change has been effective at eliminating what we believe to be incorrect errors related to user permissions accessing forge apps.

We are however still seeing a small amount of these errors, but we believe these to be legitimate based on the context we are seeing in our logs.

If customers are still experiencing these errors and you believe this to be a fault, than please contact us through our usual support channels so that we can help investigate this individual scenario.
Posted Mar 07, 2023 - 23:20 UTC
Monitoring
Intermittent issues in Forge Function Invocation

We understand that some Jira customers would be receiving the error 'Something went wrong User did not have access to specified resource' incorrectly, likely since a change was introduced on the 27th February related to how we authorise forge function invocations from Jira.

We have now reverted this change and are monitoring to confirm that this has resulted in addressing the issue.

Due to their being several legitimate scenarios for this error and their relative low volume, we will need to monitor this for at least 12 hours to ensure this change has had the intended effects of now allowing these authorised executions.

We will provide another update by 2023-03-07 23:00 in around 15 hours from now.
Posted Mar 07, 2023 - 07:28 UTC
Investigating
We are investigating reports of intermittent errors related to issues in Forge Function Invocation. The error message reported is User did not have access to specified resource. We will provide more details as we continue our investigation in approximately 1hour 0700 UTC.
Posted Mar 07, 2023 - 06:10 UTC
This incident affected: Developer (Forge Function Invocation).