Confluence searches intermittently returning incomplete or empty results
Incident Report for Atlassian Developer
Resolved
This incident has been resolved.
Posted Apr 04, 2024 - 10:39 UTC
Update
We have deployed a fix and search is now operational for all customers.
Posted Apr 04, 2024 - 10:37 UTC
Update
We are continuing to investigate this issue.
Posted Apr 04, 2024 - 08:07 UTC
Update
We have identified a potential fix to the impacted tenants and are applying the fix by reindexing. This will take ~4 hours. We are also considering alternate approaches to fix this. Until then this issue will persist.
We have not yet found the root cause of the issue and would keep investigating.
Next comms would be when the fix is done or in 6 hours whichever is early.
Posted Apr 04, 2024 - 06:51 UTC
Update
At current stage our investigation we have found that problem is most likely isolated to EU region. Only Confluence Search is impacted by intermittent empty (or limited) results. This problem is affecting only subset of Confluence sites. We are working on mitigation steps.

Next update will be shared around 6:00 UTC (unless we have more details to share earlier).
Posted Apr 03, 2024 - 18:15 UTC
Update
We are continuing to investigate this issue.

We will provide update in 1 hour or when we know more details.
Posted Apr 03, 2024 - 16:45 UTC
Update
We are continuing to investigate this issue.

We will provide update in 1 hour or when we know more details.
Posted Apr 03, 2024 - 15:37 UTC
Investigating
We are investigating incident impacting apps using Confluence Search engine. The impact observed is intermittent incomplete or empty results returned as response to search requests (using CQL).

We will provide update in 1 hour or when we know more details.
Posted Apr 03, 2024 - 14:26 UTC
This incident affected: APIs (Confluence Cloud APIs).