At 2024-05-20 03:56 UTC, a support ticket notified us of a change in the behaviour of the Forge app installation flow. Apps that were uninstalled and promptly re-installed no longer had the data in Forge Storage from their previous installation, effectively acting as a fresh installation.
Following an investigation, we have identified that: - There is no data loss. - A change was made as a part of the Forge data residency rollout, where data is now bound to the installation identifier instead of the app and site. - There was a gap in our communication with partners around this specific change. - The existing behaviour for app uninstallation, where data persisted between installations, did not match what the user interface told administrators. I.e. “Uninstalling will permanently remove this version of the app from ”. - The new behaviour of not persisting data between installations is in line with the intended experience.
As a result of the investigation, our next steps are that: - We will define and include new documentation on the Forge app installation lifecycle to clarify the expected behaviour and communicate this with partners. - We will explore options for restoration of data from previous installations directly in the admin user experience. - We will enable support to re-link data from previous installations as a part of the ECOHELP process within 14 days from app uninstallation.
This is the last communication.
Posted May 21, 2024 - 04:15 UTC
Investigating
We are currently investigating an issue related to Forge Storage and ongoing access to data as a result of site suspension or app un-installation. We have identified a change in behaviour as part of introducing support for Data Residency to Forge storage that has been progressively rolled out from the April 11th 2024. If an app is uninstalled and then reinstalled, the app will no longer have access to data stored by the app before uninstallation. While we continue this investigation we would caution users against uninstalling and reinstalling apps at this time with the expectation of data retention. We will provide another update by 2024-05-20 23:00:00 UTC, in about 16 hours from now on this investigation.
Posted May 20, 2024 - 07:02 UTC
This incident affected: Developer (Hosted storage).