Certain special characters in strings handled by Forge apps appear garbled
Incident Report for Atlassian Developer
Resolved
We have been monitoring the solution that we have rolled out yesterday to read data in its original encoding without being garbled and so far we have not observed any issues.

We consider this incident now resolved and the team will continue to monitor it.

If your app is experiencing any issues that you believe are related to this incident, please raise an
ECOHELP ticket.
Posted Sep 16, 2022 - 00:31 UTC
Monitoring
We've rolled out a solution that would allow apps to read data in its original encoding without being garbled.

We're monitoring closely and so far cannot see any occurrences of corrupted data read from secure storage.

We'll continue monitoring and provide an update over next 16 hours.
Posted Sep 15, 2022 - 09:21 UTC
Update
We are testing a solution that would allow apps to read data in its original encoding without being garbled.

If our tests are successful, we expect to begin rolling this out to the production environment in the next few hours.

Our teams will be monitoring the solution throughout the evening. We will provide our next update in another 4 hours.
Posted Sep 15, 2022 - 06:19 UTC
Update
We are still working on narrowing down the final set of instances and apps are affected.

However, we can confirm that only non-US ASCII characters are garbled if affected.

Once we have narrowed down the affected instances, we will share more information on our next steps.

We will provide an update within the next another 4 hours.
Posted Sep 15, 2022 - 02:06 UTC
Identified
We've identified that data stored in the secrets API will appear garbled only if they contain non US ASCII characters.

Product events are not affected anymore.

App installation data are not affected.

We will provide another update within the next 12 hours.
Posted Sep 14, 2022 - 14:01 UTC
Update
We've identified that only data stored in the secrets API and product events will appear garbled if they contain non US ASCII characters.

Product events should not be affected anymore but they're pending verification.

App installation data are not affected.

We are still assessing the overall impact on data and will provide another update within the next 3 hours.
Posted Sep 14, 2022 - 10:23 UTC
Update
In our previous update we shared that data stored in the secrets API and event data is affected if it contains special characters.
We would like to clarify this - at this time we know that this only applies to some non US ASCII characters which were stored between Friday and this Morning. The affected characters will appear garbled where they surface in the app, with the remainder of the data unaffected.
We have now also updated the title to better describe the impact.
We are still assessing the overall impact on data and will provide another update within the next 3 hours
Posted Sep 14, 2022 - 06:31 UTC
Update
We are investigating an issue impacting following capabilities.

- Jira product events in Forge: The event data sent in the payload of the event is corrupted, if it contains special characters.

- Secrets API in Forge hosted storage: The data stored in the secrets API is corrupted, if it contains special characters.

- App installation data could be impacted, we are still investigating.

- We are still assessing the overall impact on data integrity caused by this issue.

- Connect apps are not impacted by this incident.

We have determined the root cause for this incident and team is working on testing the fix and rolling it out.

We will provide an update within the next 3 hours.
Posted Sep 14, 2022 - 04:34 UTC
Investigating
Product events capability is affected by this incident. This issue impacts Forge apps that subscribe to JIRA product events where the payload has non english characters and it returns corrupted data.

This issue was brought to our notice 7 hours ago via CDAC.

We have identified the root cause of this issue and we are testing the fix. You can expect the next update in 3 hours.
Posted Sep 13, 2022 - 23:42 UTC
This incident affected: APIs (Product Events) and Developer (Hosted storage).