Issues installing some apps using Connect on Forge

Incident Report for Atlassian Developer

Resolved

Between 20:00 UTC May 19th to 07:55 UTC May 20th, some apps using Connect on Forge were experiencing installation failures. The issue has been resolved and the service is operating normally.
Posted May 20, 2025 - 09:12 UTC

Identified

A fix for an issue relating to problems installing Connect on Forge apps in some cases has been identified and is currently underway to mitigate this issue. We will provide further update when this issue has been resolved.
Posted May 20, 2025 - 05:01 UTC

Investigating

We are aware of some users having issues installing Connect on Forge apps. Our team is investigating with urgency and will provide an update when available.
Posted May 20, 2025 - 04:28 UTC
This incident affected: Developer (App Deployment).