Forge Jira issue panels experiencing incorrect value of localId
Incident Report for Atlassian Developer
Resolved
Between Feb 3rd and May 11th the value of localId parameter passed via productContext to Forge Jira Issue Panel extension points is incorrect. This may impact, in some cases, the ability to persist data against this parameter in case of Apps using multiple issue panels on a single issue.

The issue has been resolved for all affected apps. If you experience any further problems please contact Developer and Marketplace support (https://developer.atlassian.com/support).
Posted May 22, 2023 - 13:11 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2023 - 13:03 UTC
Monitoring
Since Feb 3rd the value of localId parameter passed via productContext to Forge Jira Issue Panel extension points is incorrect. This may impact, in some cases, the ability to persist data against this parameter in case of Apps using multiple issue panels on a single issue.

The fix has been implemented and enabled for every new app, thus preventing the issue from spreading further. As mentioned in the previous update, the existing app installations will continue to receive an incorrect value. Affected partners will be contacted directly after the Easter break.
Posted Apr 07, 2023 - 10:10 UTC
Identified
Since Feb 3rd the value of localId parameter via productContext to Forge Jira Issue Panel extension points is incorrect.

The value of localId parameter is incorrectly equal to extensionId parameter for Forge Jira Issue Panels. This may impact the ability to persist data against this parameter in case of multiple issue panels on single issue (when 'allowMultiple' configuration parameter is set to 'true').

Team is working on fix that would bring back the correct value of localId parameter for _new_ app installations. The existing app installations will continue to receive incorrect value and the team will work on mitigation steps in coming days. This may require updates to app code that will be described exhaustively in following communication.

This fix shouldn't cause any impact on Forge apps that are using Forge Jira Issue Panels without "allowMultiple" set to true.

We will provide another update by 2023-04-07 8:00 UTC, in 17 hours from now.
Posted Apr 06, 2023 - 15:18 UTC
Investigating
Since Feb 3rd the value of localId parameter via productContext to Forge Jira Issue Panel extension points is incorrect.

The value of localId parameter is incorrectly equal to extensionId parameter for Forge Jira Issue Panels. This may impact the ability to persist data against this parameter in case of multiple issue panels on single issue (when 'allowMultiple' configuration parameter is set to 'true').
Posted Apr 06, 2023 - 15:18 UTC
This incident affected: APIs (Jira Cloud APIs).