Applications unable to attach attachments to issues
Incident Report for Atlassian Developer
Resolved
Between 2021-02-04T23:34 UTC to 2021-02-04T00:30, vendor Apps using the JWT query parameter to authorise the /attachment endpoint to attach an attachment to Jira Core, Jira Service Management, Jira Software were receiving a 404.

The issue has been resolved and the service is operating normally.

We recommend using the HTTP header over the query parameter to set the JWT token for all requests to Jira.
Posted Feb 05, 2021 - 22:39 UTC
Identified
We continue to work on resolving the Attachment functionality for certain Vendor Apps for Jira Core, Jira Service Management, Jira Software, and Atlassian Developer. We have identified the root cause and expect recovery shortly.

Apps using the JWT query parameter on the /attachment endpoint are receiving a 404.
A fix is being prepared and deployed from our end.
In the meantime, App Vendors can update their app to use the JWT header for authentication on the /attachment endpoint.
Posted Feb 05, 2021 - 17:03 UTC
Investigating
We are investigating reports of applications unable to attach attachments to issues in Jira Core, Jira Software and JSM. We will provide more details once we identify the root cause.
Posted Feb 05, 2021 - 14:32 UTC
This incident affected: APIs (Jira Cloud APIs).