Some Forge and 3LO apps calling Jira product APIs are being rate limited resulting in the app not loading
Incident Report for Atlassian Developer
Resolved
The impact of this incident has been mitigated and our monitoring tools confirm that the rate-limiting is back to the pre-incident behavior.

We have increased the rate limit for Jira APIs while we continue investigating the root cause of the problem.

High-level timeline:
- 22nd of September: impact started
- 4th of October: noticeable increase of impact
- 6th of October: impact resolved

Our teams are committed to continuing to investigate the problem until we are certain about its root cause so that we can implement the correct measures to prevent this issue from reoccurring.

We are now marking this incident as resolved.

We apologize for the problems this caused our developers, partners, users, and customers.
Posted Oct 06, 2022 - 07:29 UTC
Update
The investigation is still ongoing and we are narrowing down the possible root cause of the issue but have not identified it yet.

This incident is experienced in Forge and 3LO apps.
There is no known impact to Connect apps.

On September 22, there has been an increase in requests hitting the rate limiting threshold with a noticeable increase on October 4.

We have not identified a viable workaround to be applied by users or app developers.

You can expect the next update here at 06:30 UTC.
Posted Oct 06, 2022 - 04:07 UTC
Investigating
Some Forge apps calling Jira product APIs are failing with an HTTP 429 code. This is causing the impacted apps to not load.

We are currently investigating the issue and trying to identify the root cause. We'll send another update at 03:56 UTC
Posted Oct 06, 2022 - 01:57 UTC
This incident affected: APIs (Jira Cloud APIs).