Confluence macro app rendering degradation

Incident Report for Atlassian Developer

Resolved

This incident was resolved by hotfix and rolled out to all environments by 2024-12-02 07:06 UTC.

We apologize for any inconveniences this may have caused you, your team, and our mutual customers.
Posted 4 months ago. Dec 03, 2024 - 03:40 UTC

Monitoring

A hotfix is rolling out to all environments and expected to complete within the next 2 hours. We will continue to monitor the issue during this time and provide an update to confirm the impact is mitigated.
Posted 4 months ago. Dec 02, 2024 - 04:26 UTC

Identified

We have identified the root cause in a code path that processes the response from loading static macro content. A fix has been produced and is going through QA to ensure the issue is resolved before rolling out to all sites. We expect to resolve the issue across all Confluence sites by the end of the day.
Posted 4 months ago. Dec 02, 2024 - 02:11 UTC

Investigating

We have identified a problem with Connect where Confluence macro rendering is degraded. We are investigating the root cause and will provide another update by 02:00 UTC.
Posted 4 months ago. Dec 02, 2024 - 01:33 UTC
This incident affected: APIs (Confluence Cloud APIs).