Forge CLI version 5.0.0 installation or upgrade is failing when running on npm 8
Incident Report for Atlassian Developer
Resolved
We confirm that this incident is fully resolved. The root cause of the Forge Command Line Interface (CLI) upgrade and installation issue was identified.
Users can now upgrade and install the latest stable version of Forge CLI (4.5.2)

This incident is now closed.

The problem started at 00:32 UTC on the 31st of August 2022 when the 5.0.0 version of the Forge CLI was released and recovered at 02:34 UTC on the 6th of September. During this incident, upgrading or installing the latest Forge Command Line Interface CLI 5.0.0 was returning an error related to gyp and Python where users were running npm 8.

We resolved the issue by repointing the 'latest' Forge CLI tag to the stable version 4.5.2.

In the next few days, our team will conduct a post-incident review. This will be shared here.

Atlassian Forge team
Posted Sep 06, 2022 - 03:12 UTC
Identified
Upgrading or installing the latest Forge Command Line Interface (CLI) 5.0.0 returns an error related to gyp and Python where users are running npm 8.
Upgrading will fail, however the currently installed version remains functional.

Workaround
If the Forge CLI was not already installed, use the following command to install the previous working version:
npm install -g @forge/cli@4.5.2

The problem started at 00:32 UTC on the 31st of August 2022 when the 5.0.0 version of the Forge CLI was released.

We have identified the root cause and we are actively working on fixing the problem.

You can expect the next update here within 3 hours.
Posted Sep 06, 2022 - 02:01 UTC
This incident affected: Developer (Forge App Installation).