Forge direct app distribution is not available for some users
Incident Report for Atlassian Developer
Resolved
This incident has been resolved.
Posted Mar 23, 2022 - 23:18 UTC
Monitoring
Multiple fixes have been implemented and we are monitoring the results.
Posted Mar 23, 2022 - 02:04 UTC
Update
We have rolled out some changes yesterday that should reduce the number of people running into issues like "Your app has already been installed on this site".

We are going to update the UI slightly for multiple product apps in the next couple of days to make it less confusing and more reliable for everyone.
Posted Mar 21, 2022 - 23:58 UTC
Identified
We have identified the causes of the majority of the issues developers face when using this feature and are currently working on rolling out changes over the next couple of days to address them.

What we have done so far:
- Disabled the installations tab (this is a temporary change until we have a more permanent fix for people who are admin of large number of sites)
- Adjusted our polling intervals to avoid getting rate limited

What is coming soon:
- Check whether an installation exist on a site before allowing users to install on that site
- Monitor changes made on our polling intervals and verify whether the fix worked as expected
Posted Mar 21, 2022 - 00:15 UTC
Investigating
We are investigating reports of intermittent errors for Forge direct app distribution. Our initial exploration suggests that most of the affected users have admin access to a large number of sites. We made some minor changes to confirm our guess.

We will provide more details once we confirm the root cause.
Posted Mar 16, 2022 - 05:49 UTC
This incident affected: Developer (Forge direct app distribution).