Forge macro export failing with the new PDF export feature
Incident Report for Atlassian Developer
Resolved
The impact of this incident has been mitigated.

The incident was caused by a PDF Export redesign wherein Forge macros are partially not supported in the latest PDF exports of Confluence pages. Forge macros that implement a custom export endpoint do not render correctly in the exported PDFs. Connect macros that take longer than 2 seconds to load were also impacted causing the macro to render incorrectly in exported PDFs.

High-level Timeline:
2022-10-07 UTC: impact started
2022-10-21 UTC: all known impacted customers have been redirected to legacy PDF export functionality mitigating the incident
2022-10-25 UTC: Connect macro impact has been mitigated

To mitigate the impact on Forge Macros, the affected Confluence instances were switched to the legacy PDF export. The long-term plan is for Forge Macros to support the new PDF export which can be tracked here.

With the mitigations in place, we are now marking this incident as resolved.

If this is still impacting your app or your customers, please reach out to Developer and Marketplace Support.
Posted Oct 26, 2022 - 01:32 UTC
Identified
There are some Connect macros that are also failing with the new PDF export due to longer load times. Currently reported customers are being set to fall back to the legacy PDF export functionality. We are actively working toward mitigating the issue for all affected customers.
Posted Oct 21, 2022 - 04:43 UTC
This incident affected: APIs (Confluence Cloud APIs).