Confluence Webhooks are not being delivered

Incident Report for Atlassian Developer

Postmortem

Summary

On October 22, 2025, Confluence Cloud webhook events were not delivered to Connect apps and Forge apps that use webhooks via connectModules. This outage began after a backend deployment introduced a code change that prevented Confluence from recognizing registered webhook listeners. As a result, no webhook events were generated for approximately 20 hours, impacting apps that depend on webhooks. The issue was resolved by rolling back to a previous stable deployment. We’re taking steps to improve detection and rollback processes.

IMPACT

Between 01:12 UTC and 21:46 UTC on October 22, 2025, Confluence was unable to send out webhook events. As a result, none of the apps that rely on these events received them during this time. This includes Connect apps and Forge apps that use webhooks through connectModules.

Customers may have noticed outdated content appearing in their Marketplace apps, or new content not syncing.

ROOT CAUSE

The issue was caused by a change to Confluence backend systems. As a result, no webhook events were delivered to Connect and Forge apps that use webhooks via connectModules. This occurred because a Java class was loaded by 2 different classloaders, causing Confluence to fail to find registered webhook listeners and thus not emit events.

REMEDIAL ACTIONS PLAN & NEXT STEPS

Webhooks are a critical functionality for many apps. On this occasion, our system did not generate any errors because it was inadvertently using an incorrect version of a Java class, which was loaded by a different ClassLoader. As a result, the issue occurred silently and couldn’t be detected via existing automated error monitoring.

 

We are prioritizing the following improvement actions to help prevent this issue from reoccurring:

  • Additional integration tests to identify problems before merging code to our main branch.
  • Additional detectors and alerts to identify when webhook event volume drops below a certain threshold.
  • Exploring resync / lost event recovery mechanism without overloading Atlassian infrastructure

    • We acknowledge that the availability of Connect apps is important for our customers and ecosystem partners, and we will endeavour to provide support for these apps in line with our public roadmap for Connect end of life. You can read our announcement here: Announcing Connect End of Support: Timeline and Next Steps - Work Life by Atlassian

      While this incident primarily impacted Connect, we would like to note that Forge currently includes additional internal capabilities, such as retry Atlassian app events and internal DLQ, that could assist with recovery in these types of incidents..

      We highly encourage partners to migrate to Forge to utilize the latest webhook infrastructure.

We apologize to customers and ecosystem partners whose services were impacted during this incident; we are taking immediate steps to improve the platform’s performance and availability.

Thanks,

Atlassian Customer Support

Posted Nov 08, 2025 - 04:25 UTC

Resolved

Between 01:00 and 20:47 UTC on October 22, 2025, App Developers experienced an issue where Confluence webhooks were not being delivered. We have deployed a fix to mitigate the problem, and the service is now operating normally.

This outage did not affect Forge events. However, it did impact:
1) All Connect Apps
2) Forge apps that use webhooks via connectModules

Please note: Atlassian cannot replay or resend the missed webhook events. As a result, these events are permanently lost.

Recommended Action:
To recover, we recommend that all affected apps use their resynchronization (resync) mechanisms to fetch the latest data directly from Confluence. This will help ensure your app’s data is up to date and that any information missed during the outage is restored.

Once we complete our internal incident review process, we will publish a more detailed postmortem of what went wrong, along with steps we're taking to prevent this from happening again in the future.
Posted Oct 22, 2025 - 22:09 UTC

Update

We have identified the issue causing Confluence Webhooks to not be delivered. We are currently testing a fix internally. We will provide another update at 22:00 UTC, or sooner if the fix is applied or new information becomes available.
Posted Oct 22, 2025 - 20:07 UTC

Identified

We have identified the issue causing Confluence Webhooks to not be delivered and are in the process of applying mitigations. We will provide another update at 20:00 UTC, or sooner if the mitigation is applied or new information becomes available.
Posted Oct 22, 2025 - 19:09 UTC

Update

We are continuing to investigate the issue causing Confluence Webhooks to not be delivered. While we have not yet identified the root cause, our team is making progress. We will provide another update at 18:20 UTC, or sooner as new information becomes available.
Posted Oct 22, 2025 - 16:16 UTC

Update

We are continuing our investigation. We will provide the next update within two hours or sooner.
Posted Oct 22, 2025 - 14:20 UTC

Update

Our team continues to investigate this issue. We will provide the next update within one hour or sooner.
Posted Oct 22, 2025 - 13:14 UTC

Investigating

We are aware that Confluence Webhooks are not being delivered and our team is actively investigating the same. We shall provide next update in one hour, if not sooner.
Posted Oct 22, 2025 - 12:15 UTC
This incident affected: APIs (Webhooks).