Forge Storage Intermittently Blocking Some Apps to Forge Storage
Incident Report for Atlassian Developer
Resolved
This incident has been resolved.
Posted Apr 07, 2024 - 22:59 UTC
Monitoring
Forge apps may have received intermittent errors when calling Forge Storage. This impacted approximately 0.5% of Storage read or write requests. In Forge logs, the error would read, "Request principal is not authorized to use storage resource". Forge apps that implement retries likely detect this as an increase in retries.

We observed an increase in errors beginning March 11.

The team believe they have identified the cause and have deployed a fix. Due to the intermittent nature and low volume of errors, we will continue to monitor to ensure the issue has been fully resolved.

We will update this issue with further information once we are confident the issue is fixed.
Posted Mar 25, 2024 - 06:50 UTC
Update
We continue to investigate the issue with a small number of requests to Forge Storage failing. We will provide another update in 3 hours or earlier if we have more information to share.
Posted Mar 25, 2024 - 02:34 UTC
Update
We continue to investigate the intermittent Forge Storage failures impacting some Forge apps. We will post updates within the next hour.
Posted Mar 25, 2024 - 01:10 UTC
Investigating
In response to some support tickets raised we have identified that since 2024-03-12 there has been a significant increase in failures for Forge apps calling the Forge Storage API. These failures are affecting multiple apps and appear to be inconsistant in nature. This impacts Forge Apps ability to retrieve and/or persist data using Forge Storage.

We do not yet have any expected resolution time or mitigation for apps or customers.

We will continue to investigate the cause of this incident and provide another update by 2024-03-25 01:00.
Posted Mar 24, 2024 - 23:39 UTC
This incident affected: Developer (Hosted storage).