Jira Connect framework falling back to baseUrl instead of utilizing regionBaseUrls during app upgrade
Incident Report for Atlassian Developer
Resolved
This incident has been resolved and we have confirmed that no new cases of this incident are taking place.

The issue began at 13:00 UTC on November 9th, with remedial measures taken at 18:00 UTC the following day, November 10th.
It has been confirmed that this issue did not affect new app installations during the affected period, but only app upgrades.

We apologize for any inconveniences this may have caused you, your team, and our mutual customers. We are committed to finding and preventing the root cause of the issue.
Posted Nov 12, 2023 - 22:06 UTC
Monitoring
The issue began at 13:00 UTC on November 9th, with remedial measures taken at 18:00 UTC the following day, November 10th.

Users could not see their data as the app was targeting a wrong region.

The root cause of the issue has been found and rolled back.
We can confirm that no new cases of this particular incident are taking place. It has been confirmed that this issue did not affect new app installations during the affected period, but only app upgrades.

Data has now been recovered. We are currently monitoring the

An update will be provided around 23:00 UTC.
Posted Nov 12, 2023 - 05:41 UTC
Update
The issue began at 13:00 UTC on November 9th, with remedial measures taken at 18:00 UTC the following day, November 10th.

Users could not see their data as the app was targeting a wrong region.

The root cause of the issue has been found and rolled back.
We can confirm that no new cases of this particular incident are taking place. It has been confirmed that this issue did not affect new app installations during the affected period, but only app upgrades.

Efforts to recover the data are still ongoing.

An update will be provided around 04:00 UTC.
Posted Nov 11, 2023 - 23:58 UTC
Update
The root cause has been identified and been rolled back.
We are now working on recovering the baseUrl of the affected apps from backups to recover the functionality for the users.

We will provide another update around 07:00 UTC
Posted Nov 11, 2023 - 03:13 UTC
Update
We are continuing to work on the issue.

We have identified and mitigated the problem, new installs and upgrades won't experience the issue.
A known workaround for customers affected by this bug is to uninstall and then reinstall the app.

We are now working on the recovery for the affected customers.

We will provide another update around 02:00 UTC.
Posted Nov 10, 2023 - 21:51 UTC
Identified
We are investigating an incident in Connect for Jira cloud.

An update of Connect App may trigger a bug which results in Connect framework falling back to baseUrl instead of utilizing regionBaseUrls.

A known workaround for customers affected by this bug is to uninstall and then reinstall the app.

We are currently working on the fix.

We will provide another update around 20:30 UTC.
Posted Nov 10, 2023 - 18:06 UTC