Forge custom fields modules do not render correctly
Incident Report for Atlassian Developer
Resolved
Between 2022-12-01 23:00 UTC and 2022-12-02 11:10 UTC Forge custom fields modules did not render and they were not accessible on the issue view.

We have rolled back the change that introduced the incident.

The impact of this incident has been mitigated and our monitoring tools confirm that the module is back to the operational state.

Timeline of the impact:

2022-12-01 23:00 UTC: the code with an error was deployed to production Jira
2022-12-01 23:35 UTC: the team started getting failure alerts
2022-12-02 11:10 UTC: fix was deployed, there should be no more customer impact

We are now marking this incident as resolved.

We apologize for any inconveniences this may have caused you, your team, and our mutual customers. We are committed to finding and preventing the root cause of the issue.
Posted Dec 02, 2022 - 12:14 UTC
Identified
Starting from 2022-12-01 23:00 UTC forge custom fields modules did not render and they were not accessible on the Jira issue view.

Timeline of the impact:

2022-12-01 23:00 UTC: the code with an error was deployed to production Jira
2022-12-01 23:35 UTC: the team started getting failure alerts

To resolve the issue, we are rolling back the faulty deployment and the forge custom fields modules will resume their normal behaviour within approximately 1 hour.

We will provide another update by 2022-12-02 13:00 UTC.
Posted Dec 02, 2022 - 11:27 UTC